package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bkey="((?:ktm(?:-e|-(?:[^e\W]|e[^d\W])\w*)*-)?abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*)"`)
var str = ` 1. object{one="ab-vwxc",two="value1",key="abcd-eest-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
3. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn-ed",four="obsoleteValues"}
4. object{one="ab-vwxc",two="value1",key="abcd-e-xyz-bnn",four="obsoleteValues"}
5. object{one="ab-vwxc",two="value1",key="ktm-bb-abcd-e-xyz-bnn",four="obsoleteValues"}
6. object{one="ab-vwxc",two="value1",key="ktm-bb-abcd-ed-xyz-bnn",four="obsoleteValues"}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}