import re
regex = re.compile(r"\bkey=\"((?:ktm(?:-e|-(?:[^e\W]|e[^d\W])\w*)*-)?abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*)\"", flags=re.MULTILINE)
test_str = (" 1. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-ed-xyz-bnn\",four=\"obsoleteValues\"}\n"
" 2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}\n"
" 3. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn-ed\",four=\"obsoleteValues\"}\n"
" 4. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-e-xyz-bnn\",four=\"obsoleteValues\"}\n"
" 5. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-bb-abcd-e-xyz-bnn\",four=\"obsoleteValues\"}\n"
" 6. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-bb-abcd-ed-xyz-bnn\",four=\"obsoleteValues\"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")