using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bSMC\s\d{1,3}\.\d{1,3}(?!\.?\d)";
string input = @"blah blah SMC 14.08.040 blah
blah blah SMC 14.08 blah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}