re = /\bSMC\s\d{1,3}\.\d{1,3}(?!\.?\d)/m
str = 'blah blah SMC 14.08.040 blah
blah blah SMC 14.08 blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end