$re = '/\bSMC\s\d{1,3}\.\d{1,3}(?!\.?\d)/m';
$str = 'blah blah SMC 14.08.040 blah
blah blah SMC 14.08 blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);