const regex = new RegExp('\\bSMC\\s\\d{1,3}\\.\\d{1,3}(?!\\.?\\d)', 'gm')
const str = `blah blah SMC 14.08.040 blah
blah blah SMC 14.08 blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}