#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w]+.*\.[jp][pn]e?g$"
Local $sString = "gdgdg hdhd.jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"gdgdgd.png" & @CRLF & _
"" & @CRLF & _
"gdgd hddgd.png" & @CRLF & _
"" & @CRLF & _
"hdhdgdbdddg dgdgd.jpg" & @CRLF & _
"" & @CRLF & _
"gdgdgdf gtddfd.jpeg" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")