using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]+.*\.[jp][pn]e?g$";
string input = @"gdgdg hdhd.jpg
gdgdgd.png
gdgd hddgd.png
hdhdgdbdddg dgdgd.jpg
gdgdgdf gtddfd.jpeg
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}