re = /[\w]+.*\.[jp][pn]e?g$/m
str = 'gdgdg hdhd.jpg
gdgdgd.png
gdgd hddgd.png
hdhdgdbdddg dgdgd.jpg
gdgdgdf gtddfd.jpeg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end