$re = '/[\w]+.*\.[jp][pn]e?g$/m';
$str = 'gdgdg hdhd.jpg
gdgdgd.png
gdgd hddgd.png
hdhdgdbdddg dgdgd.jpg
gdgdgdf gtddfd.jpeg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);