package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+\d{11}|\+\d\s?\(\d{3}\)(\s?\d){7}|\+(\d[-]?){11}`)
var str = `+12345678900 +1 (801) 234 5678 +1801-234-5678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}