// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+\d{11}|\+\d\s?\(\d{3}\)(\s?\d){7}|\+(\d[-]?){11}").unwrap();
let string = "+12345678900 +1 (801) 234 5678 +1801-234-5678";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}