re = /\+\d{11}|\+\d\s?\(\d{3}\)(\s?\d){7}|\+(\d[-]?){11}/m
str = '+12345678900 +1 (801) 234 5678 +1801-234-5678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end