import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+\\d{11}|\\+\\d\\s?\\(\\d{3}\\)(\\s?\\d){7}|\\+(\\d[-]?){11}";
final String string = "+12345678900 +1 (801) 234 5678 +1801-234-5678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}