#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)=\"\s*(.*?)(?:\sMbps|\sdB)?\""
Local $sString = "var conn_down=" 13.35 Mbps";" & @CRLF & _
"var conn_up=" 0.82 Mbps";" & @CRLF & _
"var line_down=" 34.60 dB";" & @CRLF & _
"var line_up=" 19.70 dB";" & @CRLF & _
"var noise_down=" 6.10 dB";" & @CRLF & _
"var noise_up=" 6.50 dB";" & @CRLF & _
"" & @CRLF & _
"var sys_uptime="74523";" & @CRLF & _
"var lan_status="Link up";" & @CRLF & _
"var lan_txpkts="1294024";" & @CRLF & _
"var lan_rxpkts="2256747";" & @CRLF & _
"var lan_collisions="0";" & @CRLF & _
"var lan_txbs="10004";" & @CRLF & _
"var lan_rxbs="35259";" & @CRLF & _
"var lan_systime="74523";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")