import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)=\\\"\\s*(.*?)(?:\\sMbps|\\sdB)?\\\"";
final String string = "var conn_down=\" 13.35 Mbps\";\n"
+ "var conn_up=\" 0.82 Mbps\";\n"
+ "var line_down=\" 34.60 dB\";\n"
+ "var line_up=\" 19.70 dB\";\n"
+ "var noise_down=\" 6.10 dB\";\n"
+ "var noise_up=\" 6.50 dB\";\n\n"
+ "var sys_uptime=\"74523\";\n"
+ "var lan_status=\"Link up\";\n"
+ "var lan_txpkts=\"1294024\";\n"
+ "var lan_rxpkts=\"2256747\";\n"
+ "var lan_collisions=\"0\";\n"
+ "var lan_txbs=\"10004\";\n"
+ "var lan_rxbs=\"35259\";\n"
+ "var lan_systime=\"74523\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}