# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)=\"\s*(.*?)(?:\sMbps|\sdB)?\""
test_str = ("var conn_down=\" 13.35 Mbps\";\n"
"var conn_up=\" 0.82 Mbps\";\n"
"var line_down=\" 34.60 dB\";\n"
"var line_up=\" 19.70 dB\";\n"
"var noise_down=\" 6.10 dB\";\n"
"var noise_up=\" 6.50 dB\";\n\n"
"var sys_uptime=\"74523\";\n"
"var lan_status=\"Link up\";\n"
"var lan_txpkts=\"1294024\";\n"
"var lan_rxpkts=\"2256747\";\n"
"var lan_collisions=\"0\";\n"
"var lan_txbs=\"10004\";\n"
"var lan_rxbs=\"35259\";\n"
"var lan_systime=\"74523\";")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.