// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\w+)=\"\s*(.*?)(?:\sMbps|\sdB)?\""#).unwrap();
let string = "var conn_down=\" 13.35 Mbps\";
var conn_up=\" 0.82 Mbps\";
var line_down=\" 34.60 dB\";
var line_up=\" 19.70 dB\";
var noise_down=\" 6.10 dB\";
var noise_up=\" 6.50 dB\";
var sys_uptime=\"74523\";
var lan_status=\"Link up\";
var lan_txpkts=\"1294024\";
var lan_rxpkts=\"2256747\";
var lan_collisions=\"0\";
var lan_txbs=\"10004\";
var lan_rxbs=\"35259\";
var lan_systime=\"74523\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}