using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:http|https)://)?((?:[A-ZА-ЯЁ0-9](?:[A-ZА-ЯЁ0-9-]{0,61}[A-ZА-ЯЁ0-9])?\.)+(?:[A-ZА-ЯЁ]{2,6}\.?|[A-ZА-ЯЁ0-9-]{2,}(?<!-)\.?))(?:/?|[/?]\S+)$";
string input = @"http://q.we.r.t.y.y.trytry.www.ёёёёё.йё/ывёа/фыёвыфвыв/?ывавёыа&фыыёва
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}