import re
regex = re.compile(r"^(?:(?:http|https)://)?((?:[A-ZА-ЯЁ0-9](?:[A-ZА-ЯЁ0-9-]{0,61}[A-ZА-ЯЁ0-9])?\.)+(?:[A-ZА-ЯЁ]{2,6}\.?|[A-ZА-ЯЁ0-9-]{2,}(?<!-)\.?))(?:/?|[/?]\S+)$", flags=re.IGNORECASE | re.UNICODE)
test_str = ("http://q.we.r.t.y.y.trytry.www.ёёёёё.йё/ывёа/фыёвыфвыв/?ывавёыа&фыыёва\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")