import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:http|https)://)?((?:[A-ZА-ЯЁ0-9](?:[A-ZА-ЯЁ0-9-]{0,61}[A-ZА-ЯЁ0-9])?\\.)+(?:[A-ZА-ЯЁ]{2,6}\\.?|[A-ZА-ЯЁ0-9-]{2,}(?<!-)\\.?))(?:/?|[/?]\\S+)$";
final String string = "http://q.we.r.t.y.y.trytry.www.ёёёёё.йё/ывёа/фыёвыфвыв/?ывавёыа&фыыёва\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}