#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\d+\+?)+@[a-z]+\.[a-z]+"
Local $sString = "1345677+@gmail.com" & @CRLF & _
"2345678+556@gmail.com" & @CRLF & _
"hello@gmail.com" & @CRLF & _
"222@gmail.com" & @CRLF & _
"222hello@gmail.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")