package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+\+?)+@[a-z]+\.[a-z]+`)
var str = `1345677+@gmail.com
2345678+556@gmail.com
hello@gmail.com
222@gmail.com
222hello@gmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}