$re = '/(?:\d+\+?)+@[a-z]+\.[a-z]+/';
$str = '1345677+@gmail.com
2345678+556@gmail.com
hello@gmail.com
222@gmail.com
222hello@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);