const regex = /(?:\d+\+?)+@[a-z]+\.[a-z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d+\\+?)+@[a-z]+\\.[a-z]+', 'g')
const str = `1345677+@gmail.com
2345678+556@gmail.com
hello@gmail.com
222@gmail.com
222hello@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}