# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@\[([^\]\s]+)([^\]]+)\]\([^\)]+\)/[$1$2](site.com\/user\/$1)/gm;t' <<< "Hello @[Kenneth Auchenberg](user:1) its been long. Tell @[Pete Lacey](user:6) I will see him tomorrow"