package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\[([^\]\s]+)([^\]]+)\]\([^\)]+\)`)
var str = `Hello @[Kenneth Auchenberg](user:1) its been long. Tell @[Pete Lacey](user:6) I will see him tomorrow`
var substitution = "[$1$2](site.com/user/$1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}