$re = '/@\[([^\]\s]+)([^\]]+)\]\([^\)]+\)/m';
$str = 'Hello @[Kenneth Auchenberg](user:1) its been long. Tell @[Pete Lacey](user:6) I will see him tomorrow';
$subst = "[$1$2](site.com/user/$1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;