package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<meta\s[a-bA-Z][^X\-UA\-Compatible][.*]\/?>`)
var str = `<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign="center">
<td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>
<h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}