// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<meta\s[a-bA-Z][^X\-UA\-Compatible][.*]\/?>").unwrap();
let string = "<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign=\"center\">
<td><h1 style=\"display:block; font-weight:700; font-size:26;\">Niveau H1</h1>
<h2 style=\"display:block; font-weight:700; font-size:20;\">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}