const regex = /<meta\s[a-bA-Z][^X\-UA\-Compatible][.*]\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<meta\\s[a-bA-Z][^X\\-UA\\-Compatible][.*]\\\/?>', 'gm')
const str = `<h1>Ceci est <u>un test</u></h1>
<table>
<tr valign="center">
<td><h1 style="display:block; font-weight:700; font-size:26;">Niveau H1</h1>
<h2 style="display:block; font-weight:700; font-size:20;">Niveau H2</h2>
<h3>Niveau H3</h3></td>
</tr>
<tr>
<td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}