# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<meta\s[a-bA-Z][^X\-UA\-Compatible][.*]\/?>"
test_str = ("<h1>Ceci est <u>un test</u></h1>\n"
" <table>\n"
" <tr valign=\"center\">\n"
" <td><h1 style=\"display:block; font-weight:700; font-size:26;\">Niveau H1</h1>\n"
" <h2 style=\"display:block; font-weight:700; font-size:20;\">Niveau H2</h2>\n"
" <h3>Niveau H3</h3></td>\n"
" </tr>\n"
" <tr>\n"
" <td><h4>Niveau H4</h4><h5>Niveau H5</h5><h6>Niveau H6</h6></td>\n"
" </tr>\n"
" </table>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.