#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?<!__)aaa)|(bbb(?!==))|((?<!#)ccc(?!==))"
Local $sString = "aaa" & @CRLF & _
"__aa" & @CRLF & _
"__aaa" & @CRLF & _
"-aaa--yyy" & @CRLF & _
"bbb" & @CRLF & _
"bbb--" & @CRLF & _
"-bbb==" & @CRLF & _
"bbb==" & @CRLF & _
"cc" & @CRLF & _
"ccc" & @CRLF & _
"ccccccccc" & @CRLF & _
"#ccc==" & @CRLF & _
"#ccc" & @CRLF & _
"#ccc-- " & @CRLF & _
"aaacccbbb--" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")