re = /((?<!__)aaa)|(bbb(?!==))|((?<!#)ccc(?!==))/i
str = 'aaa
__aa
__aaa
-aaa--yyy
bbb
bbb--
-bbb==
bbb==
cc
ccc
ccccccccc
#ccc==
#ccc
#ccc--
aaacccbbb--
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end