using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!__)aaa)|(bbb(?!==))|((?<!#)ccc(?!==))";
string input = @"aaa
__aa
__aaa
-aaa--yyy
bbb
bbb--
-bbb==
bbb==
cc
ccc
ccccccccc
#ccc==
#ccc
#ccc--
aaacccbbb--
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}