$re = '/((?<!__)aaa)|(bbb(?!==))|((?<!#)ccc(?!==))/i';
$str = 'aaa
__aa
__aaa
-aaa--yyy
bbb
bbb--
-bbb==
bbb==
cc
ccc
ccccccccc
#ccc==
#ccc
#ccc--
aaacccbbb--
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);