#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?misU)^((sdf|xvd)[a-x][0-9]{0,1})\s+[^\s]+\s+[^\s+]\s+([^\s]+)\s+[^\s]+\s+[^\s]+\s+([^\n]*)$"
Local $sString = "NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT" & @CRLF & _
"xvdf 202:80 0 100G 0 disk /mnt/data" & @CRLF & _
"xvda1 202:1 0 8G 0 disk /"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")