using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((sdf|xvd)[a-x][0-9]{0,1})\s+[^\s]+\s+[^\s+]\s+([^\s]+)\s+[^\s]+\s+[^\s]+\s+([^\n]*)$";
string input = @"NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
xvdf 202:80 0 100G 0 disk /mnt/data
xvda1 202:1 0 8G 0 disk /";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}