const regex = /^((sdf|xvd)[a-x][0-9]{0,1})\s+[^\s]+\s+[^\s+]\s+([^\s]+)\s+[^\s]+\s+[^\s]+\s+([^\n]*)$/mis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((sdf|xvd)[a-x][0-9]{0,1})\\s+[^\\s]+\\s+[^\\s+]\\s+([^\\s]+)\\s+[^\\s]+\\s+[^\\s]+\\s+([^\\n]*)$', 'mis')
const str = `NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
xvdf 202:80 0 100G 0 disk /mnt/data
xvda1 202:1 0 8G 0 disk /`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}