const regex = /(\.(?:jpe?g|png|gif))$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.(?:jpe?g|png|gif))$', 'gmi')
const str = `src="extension.jpg
src="ext.ension.jpg
src="extension.png
src="ext.ension.png`;
const subst = `-fx$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);