$re = '/(\.(?:jpe?g|png|gif))$/mi';
$str = 'src="extension.jpg
src="ext.ension.jpg
src="extension.png
src="ext.ension.png';
$subst = "-fx$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;