import Foundation
let pattern = #"(\.(?:jpe?g|png|gif))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
src="extension.jpg
src="ext.ension.jpg
src="extension.png
src="ext.ension.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-fx$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)