re = /(\.(?:jpe?g|png|gif))$/mi
str = 'src="extension.jpg
src="ext.ension.jpg
src="extension.png
src="ext.ension.png'
subst = '-fx$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result