const regex = new RegExp('(?!\\.)\\W', 'gm')
const str = `word,1.2;3.1!4.5`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);