$re = '/(?!\.)\W/m';
$str = 'word,1.2;3.1!4.5';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;