import re
regex = re.compile(r"(?!\.)\W", flags=re.MULTILINE)
test_str = "word,1.2;3.1!4.5"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)