const regex = new RegExp('(^[a-z][a-z\\'&\\(\\) ]+\\bv\\b[a-z&\\'\\(\\) ]+(?:.*?) \\[?\\d+ \\w+ \\d{4}\\]?)', 'gmis')
const str = `R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003
H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]
GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND
ERIC JOHN WATSON CA CA51/03 26 May 2003`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}