re = /(^[a-z][a-z'&\(\) ]+\bv\b[a-z&'\(\) ]+(?:.*?) \[?\d+ \w+ \d{4}\]?)/mi
str = 'R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003
H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]
GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND
ERIC JOHN WATSON CA CA51/03 26 May 2003'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end