import re
regex = re.compile(r"(^[a-z][a-z'&\(\) ]+\bv\b[a-z&'\(\) ]+(?:.*?) \[?\d+ \w+ \d{4}\]?)", flags=re.MULTILINE | re.IGNORECASE | re.DOTALL)
test_str = ("R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003\n"
"H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]\n"
"GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND\n"
" ERIC JOHN WATSON CA CA51/03 26 May 2003")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")