// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mis)(^[a-z][a-z'&\(\) ]+\bv\b[a-z&'\(\) ]+(?:.*?) \[?\d+ \w+ \d{4}\]?)").unwrap();
let string = "R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003
H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]
GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND
ERIC JOHN WATSON CA CA51/03 26 May 2003";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}